Managing Documents

The Pixen experience starts with the Welcome window that appears when you open the app. Here, you can create a new image or animation document, open existing documents, view recent documents, and more.

Creating Documents

To get started with a single frame canvas, select Create a New Image. You can also do this from the File menu with the New Image action. You will then be prompted for the width and height of the image in pixels as well as the default background color.

If you have common sizes you frequently work with, you can save your settings as a preset by clicking the Preset popup button and selecting Save Preset As. If you then click the Preset popup button again, the preset will appear in the list, and clicking it will apply its settings. You can delete presets by selecting Manage Presets from the popup button. When you're ready to create the document, select Use this Size. An empty canvas document window will now appear.

The Basics

To begin drawing, simply start dragging the mouse in the canvas. To change the size of the brush from 1 pixel, increase the size in the Size field by entering a value or using [ / ] or Up / Down Arrow keys to increment the value 1 pixel at a time. To change the color, use the color picker visible on the left side of the screen. If it's not visible, click the color well to bring it up. You can also use the Hide / Show Color Picker command under the Window menu to toggle it. See the Tools section for more on Pixen's tools.

Saving

When you're ready to save your work, you can use the typical File > Save / Save As commands. Pixen defaults to its proprietary file format for new documents, but you can select other file formats such as PNG, JPG, GIF, SVG, HEIC, TIFF, BMP, ICO, and Adobe Photoshop. Lossy formats such as JPG and HEIC support customizing the compression quality. The PNG, TIFF, and BMP formats allow you to pick whether an alpha channel is included. Since Pixen integrates with iCloud, any documents you save to its iCloud folder will be synced with your other Macs, and Pixen for iPad.

Sharing

The Share command found under the File menu can be used to share your work via system sharing services such as Messages and Mail. You can also access this functionality from the Share button in Pixen's main toolbar.

The Upload to Pixen Gallery option allows you to publish your creations on the web and submit them for inclusion in the Pixen Gallery to make them available to the greater Pixen community. You can also share the link with your friends.

Export

You can use Pixen's Export sheet to export your work in different formats without affecting the original document. Head to File > Export to get started. Here, you can define one or more export formats, each with different scales, file types, and naming conventions. For example, in one go, you could easily export your document as a PNG at 1x scale with the name Document.png, as a PNG at 2x scale with the name Document@2x.png, and as a Windows icon in the ICO format with the name Document.ico. To add a new export format, just select the + button. Then pick the scale, file type, and naming pattern that you want.

The Export Layers command found under the File menu can be used to export each layer in your document as its own image. The name of the file will be the name of the layer.

Miscellaneous

Here are a few more tips for working with documents in Pixen:

  • If you already have a document open and want to clone it, select New Image from Copy under the File menu.
  • If you have an image copied to the clipboard, you can load it in Pixen by selecting New Image from Clipboard under the File menu.
  • Use the Rename command under the File menu to quickly rename a document.
  • Use the Move To command under the File menu to quickly relocate a document.
  • Use the Print command under the File menu to print your work.
  • Pixen supports macOS's Auto Save and Versions features so you can revert to previous versions of documents with the Revert To command. If you wish to opt-out of Auto Save, you can do so in the Settings window.
  • Sync your artwork with Pixen for iPad to view it on the go.

To learn more about Pixen or purchase the app, visit https://pixenapp.com.